VideoCentric | The Video Integration Experts

REQUIRED: UPGRADE NEEDED TO POLY STUDIO USB VIDEO BAR

News item: August 14, 2020
Poly logo

An urgent upgrade is needed to Poly Studio USB video bars with software versions 1.2 or earlier. All Poly Studio USB bars in that category must be upgraded to the latest software (1.3).  Failure to implement the recommended upgrade may result in a need to RMA the Poly Studio USB video bar.

ACTION: The upgrade procedure can be found within the bulletin located here.

Comments are closed.

Call Now